升级go1.12版本遇到的问题

2019-08-16

升级到 go1.12 碰到一个依赖版本问题

xxxxxxx/vendor/go4.org/reflectutil.typedmemmove: relocation target runtime.typedmemmove not defined for ABI0 (but is defined for ABIInternal)

解决方案:

删除 vendor 目录中的 go4.org 目录

执行:govendor update go4.org/reflectutil

总之就是更新这个包到新版

即可

=========

奶一波我的一个网站:https://v2geek.com ,欢迎大家来贩卖自己的软件。